#最新
IDEA启动报错 “java: 警告: 源发行版 11 需要目标发行版 11” 完美解决

2023-06-19 0 637

1、问题描述:
IDEA运行sringboot项目后,报错:
java: 警告: 源发行版 11 需要目标发行版 11

IDEA启动报错 “java: 警告: 源发行版 11 需要目标发行版 11” 完美解决
2、原因:
这是因为导入的项目创建时使用的是jdk11,而你的IDEA没有设置这个版本。

3、解决方案:
1、点击左上角文件->设置-> 构建、执行、部署->java编译器,然后找到报错的项目(若没有显示,点击+),右边下拉框选择版本8

IDEA启动报错 “java: 警告: 源发行版 11 需要目标发行版 11” 完美解决
2、点击左上角项目结构-> 模块 ,找到报错的项目,在源那里选择8,然后依赖那里选择自己的jdk版本,我的是jdk1.8,最后点击应用,确定。

IDEA启动报错 “java: 警告: 源发行版 11 需要目标发行版 11” 完美解决

IDEA启动报错 “java: 警告: 源发行版 11 需要目标发行版 11” 完美解决

IDEA启动报错 “java: 警告: 源发行版 11 需要目标发行版 11” 完美解决
3、除了要改上面两个地方,还有配置文件pom.xml中要加下面这句话

<properties>
<java.version>8</java.version>
</properties>

IDEA启动报错 “java: 警告: 源发行版 11 需要目标发行版 11” 完美解决
4、重新运行项目,成功
IDEA启动报错 “java: 警告: 源发行版 11 需要目标发行版 11” 完美解决

收藏 (0) 打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

慕代码 项目相关 IDEA启动报错 “java: 警告: 源发行版 11 需要目标发行版 11” 完美解决 https://www.mudaima.com/1134.html

常见问题
  • 慕代码平台上所有项目源码,都由高级工程师进行多轮测试,确保完美运行、无bug!
查看详情
  • 客服会进行运行指导,如还无法运行可联系技术远程支持,平台会员可免费调试运行,非会员会收少许调试费用!
查看详情

相关文章

发表评论
暂无评论
  • 0 +

    访问总数

  • 0 +

    会员总数

  • 0 +

    项目总数

  • 0 +

    今日发布

  • 0 +

    本周发布

  • 0 +

    运行天数

不是高价源码买不起,而是慕代码更有性价比!